Por qué no desarrollamos nuevas versiones para Blackberry, Symbian ni Windows Mobile

From waze
Jump to: navigation, search

Las versiones nuevas de waze (superiores a la 2.0) funcionan en una nueva infraestructura de los dispositivos iPhone y Android. Nuestra infraestructura previa estaba diseñada originalmente para dispositivos no táctiles y utilizaba una capa de compatibilidad que no era nativa del dispositivo. Esto nos limitaba la posibilidad de aprovechar la mayor parte de las ventajas de los nuevos dispositivos táctiles.

La nueva infraestructura deja eso de lado y se apoya en la interfaz nativa de cada sistema operativo. Esto significa una mejora importante de la interfaz de usuario, además de otras funciones nativas (animación, etc.).

En este momento tenemos planeado soportar iPhone y Android y consideraremos soportar nuevas plataformas. Sin embargo, plataformas de dispositivos más antiguos (Symbian, WM, Blackberry) no soportan ni una interfaz de usuario nativa completa, ni otras APIs en las que nos apoyamos ahora. Por este motivo, la nueva versión de waze no puede soportar esos dispositivos.

Somos conscientes que esto genera frustración en nuestros usuarios Blackberry, Symbian y WM. A pesar de eso, hemos decidido concentrar nuestros recursos y esfuerzos en los sistemas operativos más relevantes y soportados.

De todas formas, las versiones anteriores a la 3.0 se mantendrán totalmente operacionales en estos dispositivos.